<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8" />
			
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<link rel="pingback" href="https://dolphinstalk.com/xmlrpc.php" />

		<!--[if lt IE 9]>
	<script src="https://dolphinstalk.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->

	<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>

	<script>var et_site_url='https://dolphinstalk.com';var et_post_id='29598';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script>
	<!-- This site is optimized with the Yoast SEO plugin v15.8 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>How Do the Dolphins Value Running Backs After 2020? - Miami Dolphins</title>
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="How Do the Dolphins Value Running Backs After 2020? - Miami Dolphins" />
	<meta property="og:description" content="Miami’s approach to the running back position last offseason seemed logical, but it ultimately failed to produce a steady rushing attack for the Dolphins’ offense in 2020. Chris Grier and Brian Flores opted to sign veteran tailback Jordan Howard and trade a 4th round pick to the 49ers in exchange for Matt Breida. Howard was [&hellip;]" />
	<meta property="og:url" content="https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/" />
	<meta property="og:site_name" content="Miami Dolphins" />
	<meta property="article:published_time" content="2021-03-04T23:55:24+00:00" />
	<meta property="og:image" content="https://dolphinstalk.com/wp-content/uploads/Gaskin9-1.jpg" />
	<meta property="og:image:width" content="600" />
	<meta property="og:image:height" content="338" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Cameron Slaven">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="4 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://dolphinstalk.com/#website","url":"https://dolphinstalk.com/","name":"Miami Dolphins","description":"Miami Dolphins News And More","potentialAction":[{"@type":"SearchAction","target":"https://dolphinstalk.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/#primaryimage","inLanguage":"en-US","url":"https://dolphinstalk.com/wp-content/uploads/Gaskin9-1.jpg","width":600,"height":338},{"@type":"WebPage","@id":"https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/#webpage","url":"https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/","name":"How Do the Dolphins Value Running Backs After 2020? - Miami Dolphins","isPartOf":{"@id":"https://dolphinstalk.com/#website"},"primaryImageOfPage":{"@id":"https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/#primaryimage"},"datePublished":"2021-03-04T23:55:24+00:00","dateModified":"2021-03-04T23:55:24+00:00","author":{"@id":"https://dolphinstalk.com/#/schema/person/999cbe39088abbb11ab01b9487479b0c"},"breadcrumb":{"@id":"https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/"]}]},{"@type":"BreadcrumbList","@id":"https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://dolphinstalk.com/","url":"https://dolphinstalk.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/","url":"https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/","name":"How Do the Dolphins Value Running Backs After 2020?"}}]},{"@type":"Person","@id":"https://dolphinstalk.com/#/schema/person/999cbe39088abbb11ab01b9487479b0c","name":"Cameron Slaven","image":{"@type":"ImageObject","@id":"https://dolphinstalk.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/3c2c7e9fc4bf9ee656fd17c123f3c378?s=96&d=mm&r=g","caption":"Cameron Slaven"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Miami Dolphins &raquo; Feed" href="https://dolphinstalk.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Miami Dolphins &raquo; Comments Feed" href="https://dolphinstalk.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Miami Dolphins &raquo; How Do the Dolphins Value Running Backs After 2020? Comments Feed" href="https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/dolphinstalk.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<meta content="Dolphin Talk Child Theme v.1.0" name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://dolphinstalk.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://dolphinstalk.com/wp-content/themes/Extra/style.css?ver=5.6.2' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='extra-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css'  href='https://dolphinstalk.com/wp-content/themes/childtheme/style.css?ver=4.7.7' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://dolphinstalk.com/wp-includes/css/dashicons.min.css?ver=5.6.2' type='text/css' media='all' />
<script type='text/javascript' src='https://dolphinstalk.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://dolphinstalk.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://dolphinstalk.com/wp-json/" /><link rel="alternate" type="application/json" href="https://dolphinstalk.com/wp-json/wp/v2/posts/29598" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dolphinstalk.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dolphinstalk.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6.2" />
<link rel='shortlink' href='https://dolphinstalk.com/?p=29598' />
<link rel="alternate" type="application/json+oembed" href="https://dolphinstalk.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdolphinstalk.com%2F2021%2F03%2F04%2Fhow-do-the-dolphins-value-running-backs-after-2020%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://dolphinstalk.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdolphinstalk.com%2F2021%2F03%2F04%2Fhow-do-the-dolphins-value-running-backs-after-2020%2F&#038;format=xml" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><link rel="preload" href="https://dolphinstalk.com/wp-content/themes/Extra/core/admin/fonts/modules.ttf" as="font" crossorigin="anonymous"><link rel="amphtml" href="https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/amp/"><!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-121431543-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-121431543-1');
</script>

<script data-ad-client="ca-pub-7745728795063550" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><link rel="icon" href="https://dolphinstalk.com/wp-content/uploads/cropped-Fav2-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://dolphinstalk.com/wp-content/uploads/cropped-Fav2-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://dolphinstalk.com/wp-content/uploads/cropped-Fav2-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://dolphinstalk.com/wp-content/uploads/cropped-Fav2-270x270.jpg" />
<link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://dolphinstalk.com/wp-content/et-cache/global/et-extra-customizer-global-16148197054135.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /></head>
<body class="post-template-default single single-post postid-29598 single-format-standard do-etfw et_extra et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
	<div id="page-container" class="page-container">
				<!-- Header -->
		<header class="header left-right">
						<!-- #top-header -->
			<div id="top-header" style="">
				<div class="container">

					<!-- Secondary Nav -->
											<div id="et-secondary-nav" class="et-trending">
						
							<!-- ET Trending -->
							<div id="et-trending">

								<!-- ET Trending Button -->
								<a id="et-trending-button" href="#" title="">
									<span></span>
									<span></span>
									<span></span>
								</a>

								<!-- ET Trending Label -->
								<h4 id="et-trending-label">
									TRENDING:								</h4>

								<!-- ET Trending Post Loop -->
								<div id='et-trending-container'>
																											<div id="et-trending-post-29598" class="et-trending-post et-trending-latest">
											<a href="https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/">How Do the Dolphins Value Running Backs After 2020?</a>
										</div>
																			<div id="et-trending-post-29541" class="et-trending-post">
											<a href="https://dolphinstalk.com/2021/03/03/what-history-tells-us-about-trading-the-3rd-pick/">What History Tells Us About Trading The 3rd Pick</a>
										</div>
																			<div id="et-trending-post-29584" class="et-trending-post">
											<a href="https://dolphinstalk.com/2021/03/03/dolphinstalk-podcast-why-did-miami-move-on-from-van-noy-who-will-be-miamis-back-up-qb/">DolphinsTalk Podcast: Why Did Miami Move on from Van No...</a>
										</div>
																									</div>
							</div>
							
												</div>
					
					<!-- #et-info -->
					<div id="et-info">

						
						<!-- .et-extra-social-icons -->
						<ul class="et-extra-social-icons" style="">
																																														<li class="et-extra-social-icon facebook">
									<a href="https://www.facebook.com/DolphinsTalk/" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
								</li>
																																															<li class="et-extra-social-icon twitter">
									<a href="https://twitter.com/DolphinsTalk" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
								</li>
																																																																																																																																																																																																																																																																																																																																																																																																																																																																		<li class="et-extra-social-icon youtube">
									<a href="https://www.youtube.com/channel/UCx1L-PmXIO3VmUigjDa5Ggw/featured" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-youtube"></a>
								</li>
																																																																																																																																																																																</ul>
						
						<!-- .et-top-search -->
												<div class="et-top-search" style="">
							<form role="search" class="et-search-form" method="get" action="https://dolphinstalk.com/">
			<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
			<button class="et-search-submit"></button>
		</form>						</div>
						
						<!-- cart -->
											</div>
				</div><!-- /.container -->
			</div><!-- /#top-header -->

			
			<!-- Main Header -->
			<div id="main-header-wrapper">
				<div id="main-header" data-fixed-height="80">
					<div class="container">
					<!-- ET Ad -->
						
						
						<!-- Logo -->
						<a class="logo" href="https://dolphinstalk.com/" data-fixed-height="85">
							<img src="/wp-content/uploads/Logo2.png" alt="Miami Dolphins" id="logo" />
						</a>

						
						<!-- ET Navigation -->
						<div id="et-navigation" class="">
							<ul id="et-menu" class="nav"><li id="menu-item-62" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62"><a href="/home/">Home</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41"><a href="https://dolphinstalk.com/about/">About Us</a></li>
<li id="menu-item-151" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151"><a href="https://dolphinstalk.com/contact-us/">Contact</a></li>
<li id="menu-item-10981" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10981"><a href="https://dolphinstalk.com/newswire/">Newswire</a></li>
<li id="menu-item-88" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-88"><a href="#">Team Info</a>
<ul class="sub-menu">
	<li id="menu-item-63" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-63"><a target="_blank" rel="noopener" href="http://www.espn.com/nfl/team/schedule/_/name/mia/miami-dolphins">Schedule</a></li>
	<li id="menu-item-86" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-86"><a target="_blank" rel="noopener" href="https://www.miamidolphins.com/team/players-roster/">Roster</a></li>
	<li id="menu-item-122" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122"><a target="_blank" rel="noopener" href="http://www.ourlads.com/nfldepthcharts/depthchart/MIA">Depth Chart</a></li>
	<li id="menu-item-146" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-146"><a href="https://dolphinstalk.com/salary-cap/">Salary Cap</a></li>
	<li id="menu-item-10986" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10986"><a href="http://www.miamidolphins.com/team/statistics.html">Stats</a></li>
</ul>
</li>
</ul>							<div id="et-mobile-navigation">
			<span class="show-menu">
				<div class="show-menu-button">
					<span></span>
					<span></span>
					<span></span>
				</div>
				<p>Select Page</p>
			</span>
			<nav>
			</nav>
		</div> <!-- /#et-mobile-navigation -->						</div><!-- /#et-navigation -->
					</div><!-- /.container -->
				</div><!-- /#main-header -->
			</div><!-- /#main-header-wrapper -->

		</header>

				<div id="main-content">
		<div class="container">
		<div id="content-area" class="clearfix">
			<div class="et_pb_extra_column_main">
																<article id="post-29598" class="module single-post-module post-29598 post type-post status-publish format-standard has-post-thumbnail hentry category-dolphins-news et-has-post-format-content et_post_format-et-post-format-standard">
														<div class="post-header">
								<h1 class="entry-title">How Do the Dolphins Value Running Backs After 2020?</h1>
								<div class="post-meta vcard">
									<p>Posted by <a href="https://dolphinstalk.com/author/dolphinscameron/" class="url fn" title="Posts by Cameron Slaven" rel="author">Cameron Slaven</a> | <span class="updated">Mar 4, 2021</span> | <a href="https://dolphinstalk.com/category/dolphins-news/" rel="tag">Dolphins News</a> | <a class="comments-link" href="https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a></p>
								</div>
							</div>
							
														<div class="post-thumbnail header">
								<img src="https://dolphinstalk.com/wp-content/uploads/Gaskin9-1.jpg" alt="How Do the Dolphins Value Running Backs After 2020?" />							</div>
							
														
							<div class="post-wrap">
															<div class="post-content entry-content">
									<p><img loading="lazy" class="aligncenter size-full wp-image-29604" src="https://dolphinstalk.com/wp-content/uploads/Gaskin9-1.jpg" alt="" width="600" height="338" srcset="https://dolphinstalk.com/wp-content/uploads/Gaskin9-1.jpg 600w, https://dolphinstalk.com/wp-content/uploads/Gaskin9-1-300x169.jpg 300w" sizes="(max-width: 600px) 100vw, 600px" /></p>
<p><span style="font-weight: 400;">Miami’s approach to the running back position last offseason seemed logical, but it ultimately failed to produce a steady rushing attack for the Dolphins’ offense in 2020. Chris Grier and Brian Flores opted to sign veteran tailback Jordan Howard and trade a 4th round pick to the 49ers in exchange for Matt Breida. Howard was cut after Week 9 while Breida played in just 12 games, rushed for 254 yards, and failed to score a touchdown. Both additions were massive busts in Miami which forced 7th round pick Myles Gaskin and eventually UDFA Salvon Achmed to carry the load for much of the season. Gaskin had a fine season and could be a nice complementary piece, but the Dolphins must look to add a more dynamic playmaker in their backfield. </span></p>
<p>&nbsp;</p>
<p><span style="font-weight: 400;">The Dolphins’ decisions regarding the position the last offseason may tell us something about the way they view and value running backs. The front office disregarded the position entirely throughout the draft as they passed on every opportunity to snag a young back. Could that mean it’s unlikely for this regime to use a first-round pick on a top RB prospect? Will they be a bit more gun shy when it comes to filling the position via free agency following the Howard miss?</span></p>
<p><span style="font-weight: 400;">Either way, Miami will need to address the position, and here are their options in the upcoming draft as well as impending free agents:</span></p>
<ul>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;"><strong>Najee Harris</strong> </span></li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Harris is a freakish talent at his position and will warrant first-round consideration. The Heisman winner out of ‘Bama stands out in this class as the most vicious runner available. However, to get him in Miami, it would likely cost them pick #18. Running backs in the first round have a mostly bad connotation, and considering Miami’s history at the position; we cannot be sure they’re going to be interested in the price tag here. </span></li>
</ul>
<p>&nbsp;</p>
<ul>
<li style="font-weight: 400;" aria-level="1"><strong>Travis Ettiene</strong></li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;"> Some scouts have Clemson’s Ettiene ranked as the number one back in this draft. He’s an explosive playmaker and will likely be one of the top-2 backs taken. He would be a welcome addition to the Dolphins, but this one comes down to the cost of acquisition. </span></li>
</ul>
<p>&nbsp;</p>
<p><span style="font-weight: 400;">Harris and Ettiene project as the most likely backs to go in the 1st. Of course, Miami will have plenty of options in later rounds, but we will focus on the marquee talent here. </span></p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr"><a href="https://t.co/jTLjtUms4R">https://t.co/jTLjtUms4R</a> Podcast March 3rd <a href="https://t.co/9GhlDKh2ey">https://t.co/9GhlDKh2ey</a></p>
<p>&mdash; DolphinsTalk.com (@DolphinsTalk) <a href="https://twitter.com/DolphinsTalk/status/1367274930962763777?ref_src=twsrc%5Etfw">March 4, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>&nbsp;</p>
<p><span style="font-weight: 400;">Impending Free Agents: </span></p>
<ul>
<li style="font-weight: 400;" aria-level="1"><strong>Aaron Jones</strong></li>
</ul>
<ul>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;"> Jones is coming off an excellent campaign and will enter free agency as the consensus #1 back on the market. He will likely be departing from Green Bay with hopes of being a top-5 highest-paid RB in the league. He’s massively talented, but Miami is probably better off letting another team sign his checks. </span></li>
</ul>
<p>&nbsp;</p>
<ul>
<li style="font-weight: 400;" aria-level="1"><strong>Kenyan Drake </strong></li>
</ul>
<ul>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">An old friend, Kenyan Drake, will hit free agency this off-season. He seems likely to return to Arizona, where Miami traded him. He’ll never have to buy his own drinks in Miami, though, thanks to his part in the Miami Miracle. </span></li>
</ul>
<p>&nbsp;</p>
<ul>
<li style="font-weight: 400;" aria-level="1"><strong>Leonard Fournette</strong></li>
</ul>
<ul>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">SuperBowl Lenny will be hitting free agency this offseason. There were rumors that Miami may have had an interest in Fournette before his signing with Tampa Bay. He put together an effective season for the Bucs en route to a championship, but Miami can certainly do better than this. </span></li>
</ul>
<p>&nbsp;</p>
<ul>
<li style="font-weight: 400;" aria-level="1"><strong>Chris Carson </strong></li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Carson is a very intriguing free agent. He fit very well in Seattle’s offense over the last 4 seasons and can be a thumper. He played in only 12 games in 2020 while compiling 681 yards and scoring 5 touchdowns on the ground. He would be a welcome addition in Miami, and he’d likely be of a lower cost than some of the other available backs. </span></li>
</ul>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="und" dir="ltr"><a href="https://t.co/JAON9SfxqY">https://t.co/JAON9SfxqY</a></p>
<p>&mdash; DolphinsTalk.com (@DolphinsTalk) <a href="https://twitter.com/DolphinsTalk/status/1367449746919596039?ref_src=twsrc%5Etfw">March 4, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<ul>
<li style="font-weight: 400;" aria-level="1"><strong>Phillip Lindsay </strong></li>
</ul>
<ul>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Phillip Lindsay may be one of the most overlooked running backs in the league. Regardless of his performance, the Broncos seemingly attempted to phase him out of their offense consistently. He spent time splitting carries with Royce Freeman for a while, and then Denver added Melvin Gordon to the mix. Lindsay ran for over 1,000 yards in 2018 and 2019, but he was relegated to a much smaller role following Gordon&#8217;s addition. In 2020, he saw only 118 carries and rushed for 502 yards. I would put Lindsay near the top of my wishlist this offseason as a potential value monster.</span></li>
</ul>
<p>&nbsp;</p>
<ul>
<li style="font-weight: 400;" aria-level="1"><strong>Le&#8217;Veon Bell </strong></li>
</ul>
<ul>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Following his release from the Jets, Bell was rumored that narrowed down his next destination to the Chiefs and the Dolphins. Obviously, he ended up joining Kansas City and taking a ride to the Super Bowl. He’s once again on the market, but his time as a highly effective back in this league may be over. The 29-year-old RB seems like someone the Dolphins should work hard to avoid. </span></li>
</ul>
<p>&nbsp;</p>
<p><span style="font-weight: 400;">Of course, the Dolphins will have many options in the draft beyond the first-round talents listed above. Still, it will be interesting to see how the front office addresses the position this offseason following a couple of swings-and-misses last year. Will they attempt to over-correct? How much do Flores/Grier value the position? Whichever way it unfolds, it must end in the Dolphins adding talented runners to their backfield. </span></p>
																	</div>
														</div>
														<div class="post-footer">
								<div class="social-icons ed-social-share-icons">
									<p class="share-title">Share:</p>
									
		
		
		
		
		
		
		
		
		
		<a href="http://www.facebook.com/sharer.php?u=https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/&#038;t=How%20Do%20the%20Dolphins%20Value%20Running%20Backs%20After%202020%3F" class="social-share-link" title="Share &quot;How Do the Dolphins Value Running Backs After 2020?&quot; via Facebook" data-network-name="facebook" data-share-title="How Do the Dolphins Value Running Backs After 2020?" data-share-url="https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/">
				<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover" ></span>
			</a><a href="http://twitter.com/intent/tweet?text=How%20Do%20the%20Dolphins%20Value%20Running%20Backs%20After%202020%3F%20https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/" class="social-share-link" title="Share &quot;How Do the Dolphins Value Running Backs After 2020?&quot; via Twitter" data-network-name="twitter" data-share-title="How Do the Dolphins Value Running Backs After 2020?" data-share-url="https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/">
				<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover" ></span>
			</a><a href="https://plus.google.com/share?url=https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/&#038;t=How%20Do%20the%20Dolphins%20Value%20Running%20Backs%20After%202020%3F" class="social-share-link" title="Share &quot;How Do the Dolphins Value Running Backs After 2020?&quot; via Google +" data-network-name="googleplus" data-share-title="How Do the Dolphins Value Running Backs After 2020?" data-share-url="https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/">
				<span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover" ></span>
			</a><a href="https://www.tumblr.com/share?v=3&#038;u=https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/&#038;t=How%20Do%20the%20Dolphins%20Value%20Running%20Backs%20After%202020%3F" class="social-share-link" title="Share &quot;How Do the Dolphins Value Running Backs After 2020?&quot; via Tumblr" data-network-name="tumblr" data-share-title="How Do the Dolphins Value Running Backs After 2020?" data-share-url="https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/">
				<span class="et-extra-icon et-extra-icon-tumblr et-extra-icon-background-hover" ></span>
			</a><a href="http://www.pinterest.com/pin/create/button/?url=https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/&#038;description=How%20Do%20the%20Dolphins%20Value%20Running%20Backs%20After%202020%3F&#038;media=https://dolphinstalk.com/wp-content/uploads/Gaskin9-1-150x150.jpg" class="social-share-link" title="Share &quot;How Do the Dolphins Value Running Backs After 2020?&quot; via Pinterest" data-network-name="pinterest" data-share-title="How Do the Dolphins Value Running Backs After 2020?" data-share-url="https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/">
				<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover" ></span>
			</a><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/&#038;title=How%20Do%20the%20Dolphins%20Value%20Running%20Backs%20After%202020%3F" class="social-share-link" title="Share &quot;How Do the Dolphins Value Running Backs After 2020?&quot; via LinkedIn" data-network-name="linkedin" data-share-title="How Do the Dolphins Value Running Backs After 2020?" data-share-url="https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/">
				<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover" ></span>
			</a><a href="https://bufferapp.com/add?url=https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/&#038;title=How%20Do%20the%20Dolphins%20Value%20Running%20Backs%20After%202020%3F" class="social-share-link" title="Share &quot;How Do the Dolphins Value Running Backs After 2020?&quot; via Buffer" data-network-name="buffer" data-share-title="How Do the Dolphins Value Running Backs After 2020?" data-share-url="https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/">
				<span class="et-extra-icon et-extra-icon-buffer et-extra-icon-background-hover" ></span>
			</a><a href="http://www.stumbleupon.com/badge?url=https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/&#038;title=How%20Do%20the%20Dolphins%20Value%20Running%20Backs%20After%202020%3F" class="social-share-link" title="Share &quot;How Do the Dolphins Value Running Backs After 2020?&quot; via Stumbleupon" data-network-name="stumbleupon" data-share-title="How Do the Dolphins Value Running Backs After 2020?" data-share-url="https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/">
				<span class="et-extra-icon et-extra-icon-stumbleupon et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;How Do the Dolphins Value Running Backs After 2020?&quot; via Email" data-network-name="basic_email" data-share-title="How Do the Dolphins Value Running Backs After 2020?" data-share-url="https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/">
				<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;How Do the Dolphins Value Running Backs After 2020?&quot; via Print" data-network-name="basic_print" data-share-title="How Do the Dolphins Value Running Backs After 2020?" data-share-url="https://dolphinstalk.com/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/">
				<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover" ></span>
			</a>								</div>
																<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #7ac8cc;
									}
								</style>
							</div>

																				</article>

						<nav class="post-nav">
							<div class="nav-links clearfix">
								<div class="nav-link nav-link-prev">
									<a href="https://dolphinstalk.com/2021/03/03/what-history-tells-us-about-trading-the-3rd-pick/" rel="prev"><span class="button">Previous</span><span class="title">What History Tells Us About Trading The 3rd Pick</span></a>								</div>
								<div class="nav-link nav-link-next">
																	</div>
							</div>
						</nav>
						
												<div class="et_extra_other_module related-posts">
							<div class="related-posts-header">
								<h3>Related Posts</h3>
							</div>
							<div class="related-posts-content clearfix">
																<div class="related-post">
									<div class="featured-image"><a href="https://dolphinstalk.com/2020/09/02/why-leonard-fournette-isnt-a-fit-for-the-miami-dolphins/" title="Why Leonard Fournette Isn&#8217;t a Fit for the Miami Dolphins" class="post-thumbnail">
				<img src="https://dolphinstalk.com/wp-content/uploads/Grier13-3-440x264.jpg" alt="Why Leonard Fournette Isn&#8217;t a Fit for the Miami Dolphins" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://dolphinstalk.com/2020/09/02/why-leonard-fournette-isnt-a-fit-for-the-miami-dolphins/">Why Leonard Fournette Isn&#8217;t a Fit for the Miami Dolphins</a></h4>
									<p class="date"><span class="updated">September 2, 2020</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="https://dolphinstalk.com/2018/04/07/bobbys-dolphins-mock-draft-30-miami/" title="Bobby&#8217;s Dolphins Mock Draft 3.0 (Miami trades down with Packers!)" class="post-thumbnail">
				<img src="https://dolphinstalk.com/wp-content/uploads/Miami-1.jpg" alt="Bobby&#8217;s Dolphins Mock Draft 3.0 (Miami trades down with Packers!)" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://dolphinstalk.com/2018/04/07/bobbys-dolphins-mock-draft-30-miami/">Bobby&#8217;s Dolphins Mock Draft 3.0 (Miami trades down with Packers!)</a></h4>
									<p class="date"><span class="updated">April 7, 2018</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="https://dolphinstalk.com/2020/10/25/miami-dolphins-trade-deadline-options-at-wr/" title="Miami Dolphins Trade Deadline Options at WR" class="post-thumbnail">
				<img src="https://dolphinstalk.com/wp-content/uploads/Grier22-1-440x264.jpg" alt="Miami Dolphins Trade Deadline Options at WR" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://dolphinstalk.com/2020/10/25/miami-dolphins-trade-deadline-options-at-wr/">Miami Dolphins Trade Deadline Options at WR</a></h4>
									<p class="date"><span class="updated">October 25, 2020</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="https://dolphinstalk.com/2020/11/25/coach-talk-week-12-review-of-the-coordinators-press-conferences/" title="Coach Talk: Week 12 Review Of The Coordinator&#8217;s Press Conference&#8217;s" class="post-thumbnail">
				<img src="https://dolphinstalk.com/wp-content/themes/Extra/images/post-format-thumb-text.svg" alt="Coach Talk: Week 12 Review Of The Coordinator&#8217;s Press Conference&#8217;s" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://dolphinstalk.com/2020/11/25/coach-talk-week-12-review-of-the-coordinators-press-conferences/">Coach Talk: Week 12 Review Of The Coordinator&#8217;s Press Conference&#8217;s</a></h4>
									<p class="date"><span class="updated">November 25, 2020</span></p>
								</div>
																							</div>
						</div>
										
				<!-- You can start editing here. -->

<section id="comment-wrap">
			<div id="comments" class="nocomments">
			 <!-- If comments are open, but there are no comments. -->

					</div>
					<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/03/04/how-do-the-dolphins-value-running-backs-after-2020/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://dolphinstalk.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='29598' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="a51ea0fb9c" /></p><input type="hidden" id="ak_js" name="ak_js" value="159"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
		</section>
			</div><!-- /.et_pb_extra_column.et_pb_extra_column_main -->

			<div class="et_pb_extra_column_sidebar">
	<div id="text-9" class="et_pb_widget widget_text"><h4 class="widgettitle">Exclusive Offer</h4>			<div class="textwidget"><p><center><a href="http://manscaped.com/"><img loading="lazy" class="aligncenter size-full wp-image-24865" src="https://dolphinstalk.com/wp-content/uploads/Manscaped0.jpg" alt="" width="600" height="229" srcset="https://dolphinstalk.com/wp-content/uploads/Manscaped0.jpg 600w, https://dolphinstalk.com/wp-content/uploads/Manscaped0-300x115.jpg 300w" sizes="(max-width: 600px) 100vw, 600px" /> </a>DISCOUNT CODE:<br />
DolphinsTalk to save 20%</center></p>
</div>
		</div> <!-- end .et_pb_widget --><div id="do-etfw-2" class="et_pb_widget widget-do-etfw">					<h4 class="widgettitle">Follow us on Twitter</h4>		
		<a class="twitter-timeline" data-width="300" data-height="400" data-tweet-limit="2" data-theme="light" data-link-color="#3b94d9" data-border-color="#f5f5f5" href="https://twitter.com/DolphinsTalk">Tweets by @DolphinsTalk</a>
</div> <!-- end .et_pb_widget --><div id="text-3" class="et_pb_widget widget_text"><h4 class="widgettitle">Online Media</h4>			<div class="textwidget"><p><a href="https://itunes.apple.com/us/podcast/dolphinstalk-com-daily/id1289046573?mt=2"><img loading="lazy" class="alignnone size-medium wp-image-128" src="https://dolphinstalk.com/wp-content/uploads/itunes-300x113.png" alt="" width="300" height="113" srcset="https://dolphinstalk.com/wp-content/uploads/itunes-300x113.png 300w, https://dolphinstalk.com/wp-content/uploads/itunes.png 400w" sizes="(max-width: 300px) 100vw, 300px" /></a></p>
<p><a href="https://www.youtube.com/channel/UCx1L-PmXIO3VmUigjDa5Ggw?view_as=subscriber"><img loading="lazy" class="alignnone wp-image-130 size-medium" src="https://dolphinstalk.com/wp-content/uploads/youtube-300x81.png" alt="" width="300" height="81" srcset="https://dolphinstalk.com/wp-content/uploads/youtube-300x81.png 300w, https://dolphinstalk.com/wp-content/uploads/youtube-400x109.png 400w, https://dolphinstalk.com/wp-content/uploads/youtube.png 403w" sizes="(max-width: 300px) 100vw, 300px" /></a></p>
<p><a href="https://www.instagram.com/dolphinstalk/?hl=en"><img loading="lazy" class="alignnone size-medium wp-image-26134" src="https://dolphinstalk.com/wp-content/uploads/follow-insta-300x95.jpg" alt="" width="300" height="95" srcset="https://dolphinstalk.com/wp-content/uploads/follow-insta-300x95.jpg 300w, https://dolphinstalk.com/wp-content/uploads/follow-insta.jpg 600w" sizes="(max-width: 300px) 100vw, 300px" /></a></p>
<p><a href="https://www.facebook.com/IamaMiamiDolphinsFan"><img loading="lazy" class="size-medium wp-image-29432 alignleft" src="https://dolphinstalk.com/wp-content/uploads/Facebook-300x100.jpg" alt="" width="300" height="100" srcset="https://dolphinstalk.com/wp-content/uploads/Facebook-300x100.jpg 300w, https://dolphinstalk.com/wp-content/uploads/Facebook.jpg 600w" sizes="(max-width: 300px) 100vw, 300px" /></a></p>
</div>
		</div> <!-- end .et_pb_widget --><div id="text-4" class="et_pb_widget widget_text"><h4 class="widgettitle">Support The Community</h4>			<div class="textwidget"><p><a href="http://dolphinscancerchallenge.com"><img loading="lazy" class="alignnone wp-image-10987 size-full" src="https://dolphinstalk.com/wp-content/uploads/DolphinCancer.jpg" alt="" width="250" height="100" /></a> <a href="http://www.risetowin.org"><img loading="lazy" class="alignnone wp-image-10988 size-full" src="https://dolphinstalk.com/wp-content/uploads/Rise.jpg" alt="" width="250" height="100" /></a><br />
<a href="https://give.moffitt.org/site/Donation2;jsessionid=00000000.app20102b?df_id=1864&amp;mfc_pref=T&amp;1864.donation=form1&amp;NONCE_TOKEN=F01034E19259F5F2A941FC50D3A4BA82"><img loading="lazy" class="aligncenter wp-image-22572 size-full" src="https://dolphinstalk.com/wp-content/uploads/ShulaFund.jpg" alt="" width="400" height="312" srcset="https://dolphinstalk.com/wp-content/uploads/ShulaFund.jpg 400w, https://dolphinstalk.com/wp-content/uploads/ShulaFund-300x234.jpg 300w" sizes="(max-width: 400px) 100vw, 400px" /></a></p>
</div>
		</div> <!-- end .et_pb_widget --><div id="archives-2" class="et_pb_widget widget_archive"><h4 class="widgettitle">Archives</h4>		<label class="screen-reader-text" for="archives-dropdown-2">Archives</label>
		<select id="archives-dropdown-2" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://dolphinstalk.com/2021/03/'> March 2021 </option>
	<option value='https://dolphinstalk.com/2021/02/'> February 2021 </option>
	<option value='https://dolphinstalk.com/2021/01/'> January 2021 </option>
	<option value='https://dolphinstalk.com/2020/12/'> December 2020 </option>
	<option value='https://dolphinstalk.com/2020/11/'> November 2020 </option>
	<option value='https://dolphinstalk.com/2020/10/'> October 2020 </option>
	<option value='https://dolphinstalk.com/2020/09/'> September 2020 </option>
	<option value='https://dolphinstalk.com/2020/08/'> August 2020 </option>
	<option value='https://dolphinstalk.com/2020/07/'> July 2020 </option>
	<option value='https://dolphinstalk.com/2020/06/'> June 2020 </option>
	<option value='https://dolphinstalk.com/2020/05/'> May 2020 </option>
	<option value='https://dolphinstalk.com/2020/04/'> April 2020 </option>
	<option value='https://dolphinstalk.com/2020/03/'> March 2020 </option>
	<option value='https://dolphinstalk.com/2020/02/'> February 2020 </option>
	<option value='https://dolphinstalk.com/2020/01/'> January 2020 </option>
	<option value='https://dolphinstalk.com/2019/12/'> December 2019 </option>
	<option value='https://dolphinstalk.com/2019/11/'> November 2019 </option>
	<option value='https://dolphinstalk.com/2019/10/'> October 2019 </option>
	<option value='https://dolphinstalk.com/2019/09/'> September 2019 </option>
	<option value='https://dolphinstalk.com/2019/08/'> August 2019 </option>
	<option value='https://dolphinstalk.com/2019/07/'> July 2019 </option>
	<option value='https://dolphinstalk.com/2019/06/'> June 2019 </option>
	<option value='https://dolphinstalk.com/2019/05/'> May 2019 </option>
	<option value='https://dolphinstalk.com/2019/04/'> April 2019 </option>
	<option value='https://dolphinstalk.com/2019/03/'> March 2019 </option>
	<option value='https://dolphinstalk.com/2019/02/'> February 2019 </option>
	<option value='https://dolphinstalk.com/2019/01/'> January 2019 </option>
	<option value='https://dolphinstalk.com/2018/12/'> December 2018 </option>
	<option value='https://dolphinstalk.com/2018/11/'> November 2018 </option>
	<option value='https://dolphinstalk.com/2018/10/'> October 2018 </option>
	<option value='https://dolphinstalk.com/2018/09/'> September 2018 </option>
	<option value='https://dolphinstalk.com/2018/08/'> August 2018 </option>
	<option value='https://dolphinstalk.com/2018/07/'> July 2018 </option>
	<option value='https://dolphinstalk.com/2018/06/'> June 2018 </option>
	<option value='https://dolphinstalk.com/2018/05/'> May 2018 </option>
	<option value='https://dolphinstalk.com/2018/04/'> April 2018 </option>
	<option value='https://dolphinstalk.com/2018/03/'> March 2018 </option>
	<option value='https://dolphinstalk.com/2018/02/'> February 2018 </option>
	<option value='https://dolphinstalk.com/2018/01/'> January 2018 </option>
	<option value='https://dolphinstalk.com/2017/12/'> December 2017 </option>
	<option value='https://dolphinstalk.com/2017/11/'> November 2017 </option>
	<option value='https://dolphinstalk.com/2017/10/'> October 2017 </option>
	<option value='https://dolphinstalk.com/2017/09/'> September 2017 </option>
	<option value='https://dolphinstalk.com/2017/08/'> August 2017 </option>
	<option value='https://dolphinstalk.com/2017/07/'> July 2017 </option>
	<option value='https://dolphinstalk.com/2017/06/'> June 2017 </option>
	<option value='https://dolphinstalk.com/2017/05/'> May 2017 </option>
	<option value='https://dolphinstalk.com/2017/04/'> April 2017 </option>
	<option value='https://dolphinstalk.com/2017/03/'> March 2017 </option>
	<option value='https://dolphinstalk.com/2017/02/'> February 2017 </option>
	<option value='https://dolphinstalk.com/2017/01/'> January 2017 </option>
	<option value='https://dolphinstalk.com/2016/12/'> December 2016 </option>
	<option value='https://dolphinstalk.com/2016/11/'> November 2016 </option>
	<option value='https://dolphinstalk.com/2016/10/'> October 2016 </option>
	<option value='https://dolphinstalk.com/2016/09/'> September 2016 </option>
	<option value='https://dolphinstalk.com/2016/08/'> August 2016 </option>
	<option value='https://dolphinstalk.com/2016/07/'> July 2016 </option>
	<option value='https://dolphinstalk.com/2016/06/'> June 2016 </option>
	<option value='https://dolphinstalk.com/2016/05/'> May 2016 </option>
	<option value='https://dolphinstalk.com/2016/04/'> April 2016 </option>
	<option value='https://dolphinstalk.com/2016/03/'> March 2016 </option>
	<option value='https://dolphinstalk.com/2016/02/'> February 2016 </option>
	<option value='https://dolphinstalk.com/2016/01/'> January 2016 </option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-2" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</div> <!-- end .et_pb_widget --><div id="text-8" class="et_pb_widget widget_text"><h4 class="widgettitle">Tua Tagovailoa</h4>			<div class="textwidget"><p><a href="https://fanatics.ncw6.net/c/2279946/618763/9663"><img loading="lazy" class="aligncenter size-full wp-image-22422" src="https://dolphinstalk.com/wp-content/uploads/TuaAd2.jpg" alt="" width="250" height="300" /></a></p>
</div>
		</div> <!-- end .et_pb_widget --></div>

		</div> <!-- #content-area -->
	</div> <!-- .container -->
	</div> <!-- #main-content -->

	
	<footer id="footer" class="footer_columns_3">
				<div id="footer-bottom">
			<div class="container">

				<!-- Footer Info -->
				<p id="footer-info">Designed by <a href="https://www.thayer2design.com" title="Syracuse Web Designer">Thayer2Design</a> | Copyright 2018 &copy; <a href="http://www.dolphinstalk.com">Dolphins Talk</a></p>

				<!-- Footer Navigation -->
								<div id="footer-nav">
											<ul class="et-extra-social-icons" style="">
																																								<li class="et-extra-social-icon facebook">
								<a href="https://www.facebook.com/DolphinsTalk/" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
							</li>
																																									<li class="et-extra-social-icon twitter">
								<a href="https://twitter.com/DolphinsTalk" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
							</li>
																																																																																																																																																																																<li class="et-extra-social-icon instagram">
								<a href="https://instagram.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
							</li>
																																																																																																																																																																																																																																						<li class="et-extra-social-icon youtube">
								<a href="https://www.youtube.com/channel/UCx1L-PmXIO3VmUigjDa5Ggw/featured" class="et-extra-icon et-extra-icon-background-none et-extra-icon-youtube"></a>
							</li>
																																																																																																																																																										</ul>
									</div> <!-- /#et-footer-nav -->
				
			</div>
		</div>
	</footer>
	</div> <!-- #page-container -->

	
	<script type='text/javascript' src='https://dolphinstalk.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script type='text/javascript' id='extra-scripts-js-extra'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/dolphinstalk.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/dolphinstalk.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"029bd59611","timeline_nonce":"5060924b79","blog_feed_nonce":"d911ac7770","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"yes"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/dolphinstalk.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/dolphinstalk.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/dolphinstalk.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"1f0de756a9","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"ace87846b8","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","wrong_checkbox":"Checkbox","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","ab_tests":[],"is_ab_testing_active":"","page_id":"29598","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"yes","is_shortcode_tracking":"","tinymce_uri":""}; var et_builder_utils_params = {"condition":{"diviTheme":false,"extraTheme":true},"scrollLocations":["app","top"],"builderScrollLocations":{"desktop":"app","tablet":"app","phone":"app"},"onloadScrollLocation":"app","builderType":"fe"}; var et_frontend_scripts = {"builderCssContainerPrefix":"#et-boc","builderCssLayoutPrefix":"#et-boc .et-l"};
var et_pb_box_shadow_elements = [];
var et_pb_motion_elements = {"desktop":[],"tablet":[],"phone":[]};
var et_pb_sticky_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://dolphinstalk.com/wp-content/themes/Extra/scripts/scripts.unified.js?ver=4.7.7' id='extra-scripts-js'></script>
<script type='text/javascript' src='https://dolphinstalk.com/wp-includes/js/comment-reply.min.js?ver=5.6.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://dolphinstalk.com/wp-content/plugins/easy-twitter-feed-widget/js/twitter-widgets.js?ver=1.0' id='do-etfw-twitter-widgets-js'></script>
<script type='text/javascript' src='https://dolphinstalk.com/wp-content/themes/Extra/core/admin/js/common.js?ver=4.7.7' id='et-core-common-js'></script>
<script type='text/javascript' src='https://dolphinstalk.com/wp-includes/js/wp-embed.min.js?ver=5.6.2' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://dolphinstalk.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.8' id='akismet-form-js'></script>
</body>
</html>
